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 1.0 IVPC Software Reference 
IVPC for Windows controls the DS-Tracer photovoltaic I-V curve tracers.  The 
program runs under the Windows® 95 or newer operating system.  Functions 
are menu driven and may be activated using the keyboard or a mouse.  IVPC 
controls the DS-Tracer and provides a way to review stored I-V curve data files.  
The following sections describe the features of the IVPC software.   

Using a Mouse or Keyboard 

Functions of IVPC can be activated with a mouse or from the keyboard.  The 
keyboard equivalents are indicated under the menus. 

The Tab and Arrow keys are an easy way to move the cursor in IVPC.  Within 
the IVPC Data Grid use the Arrow keys to move up, down, right, and left.  Press 
the Enter or Return key to display the I-V curve of the selected file(s).  Use the 
Tab key to move to the next data entry field when taking I-V curves.  Shift-Tab 
will move backwards through the fields.  Press Alt-T when ready to take a curve. 

The menus, File, Edit, View, Options, Normalize, and Window, are accessed by 
pressing Alt-F, Alt-E, Alt-V, Alt-O, Alt-N, and Alt-W respectively.  A pull-down 
menu will be displayed.  An item is selected within the pull-down menu by 
pressing the keyboard character underlined.  For example, to select New I-V 
Curve from the File menu, press the Alt and F keys at the same time (Alt-F).  This 
action will display the pull-down menu shown in Figure 1.  Select New I-V 
Curve by pressing the N key.  Note the “N” in New Curve is underlined.  
Similarly, you could have pressed the X key to exit IVPC for Windows. 

 

  
Figure 1.  Using IVPC Menus with a Keyboard. 
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Window Control Box 

 The Window Control Box is located in the upper left corner next to the File 
menu.  This box is the standard control used on all windows whether part of 
IVPC or another application.  You will primarily use the Close command to close 
an I-V curve window.  As seen in Figure 2, you can press Ctrl+F4 to close the 
current window rather than use the mouse.  If the active window is a new I-V 
curve, you are given the option to save the I-V curve data.  Refer to Save I-V 
Curves in this section for details.  Closing a new curve returns you to the Data 
Grid window.  Refer to your Windows® manual for details on the other 
functions of the window control box. 

 
Figure 2.  Window Control Box. 

2.0  Starting IVPC for Windows 
1.  Start the control computer operating Windows®.  IVPC will operate under 

Windows 95 or newer.  Note: IVPC is installed from CD-ROM or floppy 
disks like any other Windows program.  Refer to the manual for the 
Windows version you are using. 

2.  Activate IVPC by double clicking on the IVPC icon or by using the Start 
function of Windows® as shown in Figure 3. 
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Figure 3.  IVPC for Windows icon. 

Data Grid Window 

The Data Grid window, shown in Figure 4, is the main IVPC window.  The Data 
Grid displays details of all I-V curves in the current working directory.  The grid 
displays all 18 fields of data for each I-V curve.  You may change which field is 
displayed using the Change Field command in the Edit menu or by double-
clicking on a field header within the grid menu.  Refer to the Options Menu 
section for details.  Double-clicking on any row in the grid will recall the I-V 
curve of that particular file. 

All fields may not fir on your screen. Use the scroll bars as needed to display 
other fields. Reorder fields to put the most important fields to the left side. 

The Check Boxes located on the left side of the Data Grid allow multiple curve 
selections for Merging Curves, Normalizing I-V Data, Sorting Data, Plotting 
Multiple Curves, or Deleting curves from the Data Grid.   

 

 
Figure 4.  IVPC Data Grid. 

3.0  IPVC Menus 
The IVPC software uses pull-down menus to access functions.  Most commands 
have an associated keyboard sequence to activate the function.   

3.1  File Menu 

Items under the File menu are shown in Figure 5.  Some functions may be  
disabled depending on what window is currently active.    
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Figure 5.  File Menu as seen in Data Grid Window. 

About IVPC—Displays IVPC version number and other information. 

*New I-V Curve —Used to take a new I-V curve. 

*Save I-V Curve—Saves the current I-V curve to disk. 

*Merge Files - Saves selected files to one *.ivm file 

*Delete Curve—Deletes individual or multiple curves from Data Grid. 

*Change Directory—Changes the current working directory. 

*Print—Prints the current Window to the default printer setup in Windows. 

Exit—Closes all IVPC windows and ends IVPC session. 

*These items are discussed in more detail below. 

New I-V Curves 

Selecting New I-V Curve from the File menu allows you to take an I-V curve 
using the DS-Tracer.  Before taking a curve, the DS-Tracer should be turned on 
and connected to the PV system as described in the DS-Tracer Operating Manual.   
Note:  It takes about 12 seconds to initialize the DS-Tracer hardware. 

The data entry fields are shown and the TAB key will move the cursor from field 
to field.  

Version & Range Data 

The DS-Tracer voltage and current ranges are displayed at the bottom of the 
screen.  The voltage ranges correspond to the position of the RANGE switch on 

The keyboard sequence for New I-V Curve is Ctrl+N.  IVPC will open a new 
curve window as shown in Figure 6.  This window provides areas to enter curve 
information identifying the I-V curve.  A message indicating the status of the DS-
Tracer hardware is displayed in the area normally used to plot the curve.   
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the DS-Tracer.  Leave the RANGE switch in the VHIGH position unless the PV Voc 
is lower than VLOW as displayed on the screen.  The two current ranges of a 
standard DS-100 are also shown.  Select the range needed using the radio buttons 
next to the range displays.   

Note: You will not damage the DS-Tracer by using the low current range on a 
high current module.   However, the I-V curve will be clipped off at 
ILOW if the PV Isc exceeds the ILOW value. 

 

Figure 6.  New Curve screen while DS-Tracer is pre-charging. 

 

Data Entry Fields 

Before taking an I-V curve, enter data in the fields for curve Name, Site, Sub-
System, Modules, irradiances and temperatures, Misc., and Comments.  With 
exception for the temperatures and irradiances all fields are characters strings 
allowing any type of data to be entered.   

Auto Irradiance and Temperature Measurements 
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The DS-100 can automatically measure two irradiances and two temperatures 
when an I-V curve is taken—providing appropriate sensors are attached.  Enable 
Auto measurements by checking the Auto boxes next to the irradiance or 
temperature field.  Both temperature #1 and irradiance #1 will be automatically 
measured when the curve is taken while temperature #2 and irradiance #2 can 
be used to enter data manually.  Note: The calibration constant must be set for 
the pyranometer used.  Refer to the Options Menu description for details on 
setting this constant. 

Curve Plot & Data Displays 

Prior to taking a curve, the plot area is used for status messages and the curve 
data values are all zero.  After a curve is taken, the curve is plotted and relevant 
values associated with the curve are displayed in these areas. 

Taking the I-V Curve 

After initialization, the status message changes and the Take Curve button is 
enabled as shown in Figure 7.  The status message indicates that a curve can be 
taken by using the mouse to press the Take Curve button or by pressing Alt-T. 

 
Figure 7.  DS-Tracer is Pre-charged and Ready to Immediately Take the Curve. 
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After pressing Take Curve, the DS-Tracer takes approximately 6 seconds to take 
the curve and plot the data as shown in Figure 8.  (Note: although it takes 6 
seconds to complete and display the I-V curve, curve data are acquired in less 
than 1 second.)  

 
Figure 8.  Example of I-V curve. 

The following is a brief description of the values measured by the DS-Tracer. 

Isc The array short-circuit current. 

Voc The array open-circuit voltage. 

Peak Power The maximum array power measured. 

Ipk The array current at peak power. 

Vpk The array voltage at peak power. 

Fill Factor 
Peak Power
(Isc x Voc)    x 100% 
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If You Get an Error 

There are several error messages that may be displayed when taking a curve.  A 
common error dialog is shown in Figure 9.  This error usually occurs after the 
DS-Tracer automatically turns itself off—after several minutes of no activity.  
This features helps to protect the DS-Tracer battery.  When an error occurs, 
follow the directions as given in the error dialog box. 

 
Figure 9.  Example of error dialog box. 

Other errors occur if the PV array voltage is too high or if it is zero or negative.  
(Note: Reversing the polarity when connecting the PV array should not damage 
the DS-Tracer but may cause fuses to blow and should be avoided, obviously!) 
Follow the IVPC directions given when the error occurs.  Most errors will 
happen as soon as you chose New I-V Curve from the File menu.  Most often you 
can correct the problem and continue without having to restart. 

Save I-V Curve 

Use the Save command to store new I-V curves in the current directory or to save 
changes to previously stored I-V curves.  IVPC prompts you to enter a file name 
when you save a new I-V curve.  Only the first 8 characters of the name are 
significant.  If you do not specify a file extension, IVPC appends the extension 
“.iva” to all files.  This extension indicates that this is an I-V curve data file in 
ASCII format.  You may use any file extension you want. Refer to Appendix A 
“I-V Curve ASCII File Format” for the format of these data files. 

Merge I-V Curve Files 

Use the Merge Files command to combine several “.iva” ascii curve files to one 
“.ivm” acsii merged file. To merge files,  check the Check Box next to each curve 
you wish to merge. Press the Merge Files command or Ctrl+R to combine the 
selected files. The  filename of the merged file is automatically generated by 
using the date and the number of merged files for that day.  For example, the 
first merge on 2-17-98 would save as 01021798.ivm and the second merge would 
save as 02021798.ivm. The files are saved to the active I-V curve directory.  Note:  
The Merge Files command does not affect data in the individual “.iva” files.  
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Delete I-V Curve 

Use the Delete command to delete I-V curves from the current directory.   The 
Delete Curve command is only enabled when an I-V curve or the Data Grid is 
being displayed. 

Pressing the Delete command or Ctrl+L when an I-V curve is showing will 
invoke a warning dialog box similar to Figure 10.   Press “Yes” to  delete the 
curve from the current directory.   Press “No” and no change will be made.    

Similarly, when the I-V Data Grid window is active, delete will delete all curves 
with check boxes checked. Note: Delete will permanently erase the files from 
the computer Disk! 

 
Figure 10.   Delete File Warning. 

Change Directory 

The IVPC Data Grid displays data from one sub-directory of your hard disk.  
This directory is the current working directory for all IVPC data files.  Use the 
change directory command to select another directory or to create a new 
directory.  This command displays the Change Directory dialog box shown in 
Figure 11.  Although individual I-V curve data files are shown, you cannot select 
individual files.  These file names are shown to help you locate the directory you 
want to use. 
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Figure 11.  Change Directory dialog box. 

Select the directory by clicking on it with a mouse or by using the up or down 
arrow keys to move around within the sub-directory box.  Open directories by 
double-clicking them or pressing Return while they are selected.  Use the Tab 
key to move between the various elements of the dialog box.  You may change 
disk drives using the pull-down menu in the top, center of the dialog box.  If you 
chose to make a directory, the new directory is a sub-directory off the currently 
selected directory in the dialog box. 

Print 

The Print command prints the current window to the default printer defined by 
Windows.  Use the Windows Control Panel to change default printers.  Refer to 
your Windows manual for details.  Pressing the Print command from the menu 
or Ctrl+P while an I-V curve or Multi-Plot curve is showing will print one copy 
of the active I-V curve or Multi-Plot window. 

While the Data Grid is displayed, Print will invoke a dialog box, shown in Figure 
12.  Selecting “Curves” will print one copy of each checked curve.  If “Curves” is 
selected while there are no curves checked, a dialog box will appear to tell the 
user there are no check boxes selected.  Check the boxes of the curves you wish 
to print and re-select Print from the window.  Pressing “Grid” will print one 
copy of the Data Grid.  The Data Grid print out displays the 6 fields of data that 
are currently displayed on the screen.  Press “Cancel” to close the dialog box 
without printing. 

 

 
Figure 12.  Print Curve Dialog Box.. 

3.2  Edit Menu 

Items in the Edit Menu, Figure 13, allow you to copy a graph into the clipboard, 
sort data within the Data Grid, or change the data fields displayed on the Data 
Grid.  These items are discussed in more detail below. 
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Figure 13.  Edit Menu as Seen in Data Grid Window. 

Copy 

The Copy command will copy the current graph from an I-V curve or Multi-Plot 
window into the clipboard.   This feature is useful for pasting curves into word-
processing documents.   Refer to the Windows manuals for details on pasting 
from the clipboard.   

Select All 

Use Select All to highlight all of the Data Grid cells prior to using copy. This is a 
convenient way to quickly copy all the data grid information to the clip board. 

Sort 

The Sort command is enabled while the Data Grid is displayed and sorts a 
column of data either alphabetically or numerically.    Selecting any column or 
column header activates that column for sorting.   After selecting a column, sort 
the data in that column by choosing Sort from the menu or by pressing Ctrl+0.   
For example, to sort Irrad.  #1 data, select any cells within the Irrad.  #1 data 
column, as shown if Figure 14, and press Ctrl+0. 

 
Figure 14.  View of Grid Before Sort Command 

After the Data Grid is sorted using Irrad.  #1 data the result is shown in Figure 15.   
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Figure 15.  View of Grid After Sort. 

Selecting anywhere within the Check Box column will activate the Check Box 
column.   To sort data using the check boxes, check the I-V curves that you wish 
to sort.   After selecting the check boxes select Sort from the menu or press 
Ctrl+O to sort data.   The Data Grid will display the “checked” curves at the top 
of the Data Grid in the order that they were checked. 

Change Field 

Use Change Field to select the data fields to display on the I-V Data Grid or 
Multi-Plot data grid.  Select from the scroll list shown in Figure 16.  The change 
affects the Data Grid column currently selected.  Select a column by clicking 
anywhere in the column with the mouse or by moving to the column using the 
arrow keys. 

 
Figure 16.  Change Field dialog box. 

Check All 

Pressing the Check All command or Ctrl+E will automatically check all check 
boxes on the I-V Data Grid. 

UnCheck All 

Pressing the UnSelect All command or Ctrl+U will automatically un-check all 
check boxes on the I-V Data Grid. 
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3.3  View Menu 

Multi-Plot Curves 

The View menu, shown in Figure 17, contains the Multi-Plot Curves command, 
which is used to display multiple I-V curves and their data.  Use the Check Boxes 
to select the curves you wish to plot.  Choose Multi-Plot Curves from the menu 
or press Ctrl+M to plot the chosen curves on the same grid. 

  

 
Figure 17.  View Menu as Seen in Data Grid Window. 

After issuing the Multi-Plot Curves command, a window similar to the one 
shown in Figure 18 appears.  The window contains a multi-plot graph, a graph 
legend, and a data grid that contains information for the individual curves.  The 
graph plots the individual curves with a different color, and presents a 
corresponding color legend.  The legend uses a number and the curve name to 
identify the individual curves.  The legend number corresponds to the Data Grid 
row.  The multi-plot graph can be printed by choosing the Print command from 
the window or by pressing Ctrl+P.  Note:  The multi-plot graph is a color graph, 
therefore, to get the best print results a color printer should be used. 

The data fields in the multi-plot grid may be changed using the same methods 
used for the I-V data grid.    
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Figure 18.   Multi-Plot Window. 

3.4  Options Menu 

Use the Options menu, shown in Figure 19, to set  
• pyranometer constants for the DS-100,  
• set the DS-100 to automatically take I-V Curves,  
• change the COM port used for the DS-Tracer, and 
• format the I-V plots with Grid Lines and/or Symbols. 
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Figure  19. Options Menu Functions 

Pyranometer Constants (DS-100 only) 

Selecting Pyranometer Constant from the Options menu allows you to enter the 
conversion constant for each of the two Pyranometer (irradiance) inputs of a DS-
100.  The constants should be entered in mV per 1000 W/m2.  For example, a 
typical pyranometer will produce 10 mV under full sun (1000 W/m2).  Therefore 
enter 10 as shown in Figure 20.    

Temperature compensation adjusts the signal for changes in the sensor 
temperature.   To compensate the signal, select the temperature source to use for 
compensation.   Selecting a source, except for none, will enable the Temperature 
Coefficient text box and the Reference temperature text box.  Enter the values 
you wish to use in units of 1/°C for the temperature coefficient and °C for the 
reference temperature.  Temperature compensation is more commonly used for 
reference cells. 

Pyranometer Constants can automatically be written to the Comment Box of each 
new curve by selecting the Write Pyranometers Constants to Comment Box 
check box.  

If changes are made to the Pyranometer Constants window press “OK” to save 
the new values or “Cancel” to ignore it. 
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Figure 20.  Pyranometer constant dialog box. 

Auto Curves 

Selecting Auto Curves from the Options Menu (Ctrl + A) causes the display 
shown in Figure 21 to appear.  Using this form, the user inputs information to set 
the DS-100 to automatically take I-V Curves.   
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Figure  21.  Automatic Curve Taking with the DS-100 

Note:  Real time Temperature and Irradiance values will be displayed in the “Current” 
windows for all connected sensors.  These values will be updated approximately 
once per second except immediately before an I-V curve is taken. 

Selecting the Enabled button activates the Auto Curve feature.  If no Trigger 
Range criteria have been selected, the DS-100 will immediately take an I-V 
Curve.  The Trigger Ranges control when the DS-100 automatically takes an I-V 
Curve.  The user-input values are Count, Time Range, Irradiance #1, Irradiance 
#2, Temperature #1, and Temperature #2.  The preset conditions of any and all 
parameters selected MUST be met before an I-V curve is taken.  Note:  Never 
select a parameter unless an appropriate sensor is connected to the input.   

The Delay box, set by the user, contains the interval between I-V Curves.  This 
value is used to take curves at regular intervals during a Time Range when no 
Trigger criteria are set.  The minimum value that can be entered in the Delay box 
is 45 seconds.   
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The Current Time box displays the PC time.  The Next Curve text box displays 
the time when the next I-V Curve will be taken.  If any Trigger Range criterion 
have been selected and not met, “Triggered” will appear in the Next Curve text 
box.  Note: The Curve Tracer will start it’s pre-charging cycle 20 seconds before 
the Next Curve is to begin. The Curve Tracer will then sweep the I-V Curve 
when Current Time equals Next Curve Time. 

The Curve Count text box displays the number of I-V Curves that have been 
taken since Auto Curve was enabled.  This value can be reset to zero by selecting 
the Reset Curve Count button located in the Count box under Trigger Ranges. 

User inputs in the Auto curve window may be saved.  Selecting the Save button 
saves the criteria for the next test session.  Selecting Don’t Save will unload the 
form and the DS-100 will revert to the last saved criteria for the next test session. 

Count: 

The Count criteria allows the user to set a limit on the number of I-V Curves to 
be taken.  When Curve Count equals the Maximum # of  Curves input, no more 
I-V Curves will be taken.  A dialog box will appear telling the user that Curve 
Count has reached the preset limit.  No more I-V curves are taken until the 
criteria are changed by the operator. 

Time Range: 

The Time Range allows the user to select a time frame over which I-V Curves are 
taken.  When the Current Time is greater than or equal to Start time and less than 
or equal to Stop time, I-V Curves may be taken using the interval set with the 
Delay input (See Above) or when Trigger criteria are met.  A dialog box will 
appear to inform the user when the Stop Time has been reached.  No more I-V 
curves are taken until the criteria are changed by the operator.  Note: If Time 
Range is enabled, the Curve Tracer will start it’s pre-charging cycle 20 seconds 
before the set Start Time. The Curve Tracer will then sweep the I-V Curve 
when Current Time equals Start Time. 

Irradiance #1 and Irradiance #2:   

The Irradiance #1 and Irradiance #2 inputs allows the user  to select an irradiance 
window in which an I-V Curve is taken.  When the Current Irradiance meets the 
preset conditions an I-V Curve is taken.  If both Irradiance #1 and Irradiance #2 
inputs are selected, conditions must meet both criteria to trigger an I-V curve.  
Current Irradiance will read “N/A” unless a DS-100 connected.  A dialog box will 
appear reminding the user that a DS-100 must be connected to use this feature.   

Temperature #1 and Temperature #2:  

The Temperature #1 and Temperature #2 inputs allows the user  to select a 
Temperature window in which an I-V Curve is taken.  If both temperature inputs 



IVPC Software Reference page 19 

 19

are selected, conditions must meet both criteria to trigger an I-V curve.  Current 
Temperature will read “N/A” unless a DS-100 connected.  A dialog box will 
appear reminding the user that a DS-100 must be connected to use this feature. � 

COM Port 

Selecting COM Port from the Options menu allows you to identify which COM 
port of your computer is used with the DS-Tracer.  Typically you will select COM 
port 1 for notebook computers.  To change the current COM port, select the COM 
Port command from the menu.   This will cause a dialog box, Figure 22, to appear.  
Simply enter the number of the port and press OK to change or Cancel to ignore. 

 

 
Figure 22.  COM Port dialog box. 

Graph  

Choosing the Graph command will invoke a sub-menu, shown in Figure 23.  The 
sub-menu contains the Grid Lines and Symbols commands that are used to 
change the appearance of the graph.   Checking the Grid Lines command 
produces grid lines on the graphs.  Checking the Symbols command produces a 
symbol for each data point that is plotted on the graph.   

 

 
Figure 23.  Graph Options Sub-Menu. 
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3.4  Normalize Menu 

The Normalize window, shown in Figure 24, contains the Normalize Now, Set 
Constants, and Auto-Normalize commands.  These commands normalize I-V 
curve data, set the normalization constants, and to allow the user to 
automatically normalize data when taking a new I-V curve.  Normalizing an I-V 
curve numerically translates measurement data from the test conditions to 
standard reporting conditions (SRC) or to user-specified reporting conditions.  
The Normalized data can then be used to form a comparison of different PV 
modules among a group. 

 

 
Figure 24.  Normalize Menu as Seen in Data Grid Window. 

Normalize Now 

The Normalize Now command is enabled when an I-V curve or the I-V Data 
Grid is being displayed.  To normalize data from an I-V curve window, first set 
the values of irradiance and temperature to which the curve is to be normalized.  
The set constants menu allows you to choose which irradiance source, Irrad.  #1 
or Irrad.  #2, and which temperature source, Temp. #1 or Temp. #2, to use for 
normalizing.  After verifying that the irradiance and temperature values are 
correct, choose the Normalize Now command from the Menu or press Ctrl+Z.  
This will normalize the data and create a new window, similar to Figure 25, 
which displays a graph of the original I-V curve and the normalized curve.  The 
normalized I-V curve window allows the user to view either the normalized I-V 
data or the original I-V data from the text boxes.  To “toggle” between the data 
sets, simply select the buttons, located on upper-right of the window.  The 
Normalization File text box, located on lower-left window, displays the 
normalization file which was used to normalize the I-V data. 
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 Figure 25.  Normalized I-V Curve Window. 

Note:  Selecting the Save command from the menu while a normalized I-V 
curve window is being displayed only saves the normalized data.  To save 
original I-V Data, you must return to and save the original I-V curve Window. 

Note:  After saving normalized data and closing the normalized I-V curve 
window, you must use the Multi-Plot Function to re-plot the two curves 
together again.  Double-clicking on the normalized I-V  curve from the Data 
Grid will only load and display the normalized graph and data. 

To normalize I-V curves from the I-V Data Grid, check the boxes of the curves 
you wish to Normalize and select Normalize Now from the menu or press 
Ctrl+Z.  All selected curves will be normalized and saved automatically with an 
“_N” attached to the filename.  If the filename already exists, you will be asked 
to enter a new filename for the normalized I-V curve. 

Set Constants 

Selecting the Set Constants command displays a window that allows you to set 
normalization parameters. The Normalization Constants window allows you to 
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choose one method of normalization, Approximation, ASTM-E1036-93, or 
ASTM-E1036-96.    

Approximation Method 

Selecting the Approximation button, located in the upper-left window, will 
invoke a window similar to Figure 26.  The Approximation method of 
normalization uses the following equations to calculate the normalized I-V data: 
 

Io = I + Isc(Eo/E - 1) 
Vo = V + b*Voc(To - T) - DI*Rs 
where: 

Io = normalized current, A 
I = measured current, A 
Isc = measured short-circuit current, A 
Eo = irradiance at standard conditions, W/m2 
E= irradiance, W/m2 
V = measured voltage, V 
Vo = normalized voltage, V 
Voc = measured open-circuit voltage, V 
To = temperature at standard conditions, °C 
T = measured temperature, °C 
b = voltage temperature coefficient of device under test, 1/°C   
Rs = Series Resistance, Ohms 
 
Note: Rs is automatically estimated from I-V data when using the 

Approximation  method. 
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Figure 26.   Normalization Constants Window with Approximation Selected. 

New parameter sets can be added to the approximation file by selecting “Add” 
from the upper-right window.  Selecting “Add” clears the text boxes and allows 
you to enter new normalization constants.  Selecting “Save” will save the new 
constants.  Selecting “Done” saves the constants and closes the Normalization 
Constants window.   Note:  Selecting “Add” in the Approximation  method 
will automatically give b(Beta) a value of -0.005 per  °C, but this value may be 
changed to meet your specifications. 

To select an existing normalization constant set, Use the List box and select a file 
using the Arrow keys or use the Mouse to click on a file.   Selecting “Save” or 
“Done” will make the current set the active normalization constants. 

Sets can be removed(deleted) by selecting a file and pressing “Remove”.   After 
removing a set, it is deleted from the List box. 

You may choose which temperature and irradiance source to use, Temp.  #1 or 
Temp.  #2 and Irrad.  #1 or Irrad.  #2, when normalizing I-V data.  To make these 
values valid, you must select “Save” or “Done after making a change. 
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ASTM-E1036-93 Method 

Selecting the ASTM-E1036-93 button, located on the upper-left window, will 
invoke a window similar to Figure 27.  The ASTM-E1036-93 method of 
normalization uses the following equations to calculate the normalized I-V data: 
 

Io = I + I[(Eo/E - 1) + a(To - T)] 
Vo = V + b(To - T) - DI*Rs - K*Io(To-T) 

where: 
I = measured current, A 
Io = normalized current, A 
Isc = measured short-circuit current, A 
Eo = irradiance at standard rated conditions (SRC), W/m2 
E= irradiance, W/m2 
V = measured voltage, V 
Vo = normalized voltage, V 
Voc = measured open-circuit voltage, V 
To = temperature at standard rated conditions, °C 
T = measured temperature, °C 
a = temperature coefficient of device under test, 1/°C   
b = temperature coefficient of device under test, V/°C   
Rs = Series Resistance, Ohms 
K = curve correction factor, Ohms/°C 

Note:  a(alpha) is typically a positive number and b(Beta) is typically a 
negative number.   If the value of Rs is unknown, enter a negative 
number and it will be automatically calculated from the curve data. 
Enter a 0 for curve correction factor, K, if unsure of its value. 
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Figure 27.  Normalization Constants Window with ASTM-E1036-93 Selected.. 

 

Changing the temperature and irradiance values and adding, selecting, and 
removing files in the ASTM-E1036-93 window is the same as in the 
Approximation window. 

For more information on ASTM-E1036-93 standard test methods, review the 
ASTM manual entitled ASTM Designation: E1036/E1036M - 93—Standard Test 
Methods for Electrical Performance of Non-Concentrator Terrestrial Photovoltaic 
Modules and Arrays Using Reference Cells. 

 

ASTM-E1036-96 Method 

Selecting the ASTM-E1036-96 button, located on the upper-left window, will 
invoke a window similar to Figure 28.  The ASTM-E1036-96 method of 
normalization uses the following equations to calculate the normalized I-V data: 

Io = (I * (Eo/E)) / (1+ aE  * Tc - aEo * To) 

Vo = V / ((1 + bE * Tc - bEo * To)(1 + dTc * ln(E) - dTo * ln(Eo))) 
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where: 

I = measured current, A 

Io = normalized current, A 

V = measured voltage, V 

Vo = normalized voltage, V 

Eo = irradiance at standard rated conditions (SRC), W/m2 

E= irradiance, W/m2 

To = temperature at standard rated conditions, °C 

T = measured temperature, °C 

aE = Current-Temperature function of device under test, 1/°C 

aE0 =  Current-Temperature function of device under test, 1/°C 

bE = Voltage-Temperature function of device under test, 1/°C 

bE0 = Voltage-Temperature function of device under test,  1/°C 

dT  = Voltage-Irradiance Correction Factor, dimensionless 

dTc  = Voltage-Irradiance Correction Factor, dimensionless 

Note: a(alpha) is typically a positive number and b(beta) is typically a negative 
number.   d(delta) is typically a small positive number. If d(delta) is unknown, 
set to 0. 
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 Figure 28.  Normalization Constants Window with ASTM- Selected. 

Changing the temperature and irradiance values and adding, selecting, and 
removing files in the ASTM-E1036-96 window is the same as in the 
Approximation window. 

For more information on ASTM-E1036-96 standard test methods, review the 
ASTM manual entitled ASTM Designation: E1036/E1036M - 96—Standard Test 
Methods for Electrical Performance of Non-Concentrator Terrestrial Photovoltaic 
Modules and Arrays Using Reference Cells. 

 

Auto-Normalize 

Checking the Auto-Normalize command causes new curves to be automatically 
normalized.  This feature saves time when taking and normalizing new curves.   
Auto-normalize uses the same methods that are used by selecting Normalize 
Now from the menu are by pressing Ctrl+Z, therefore, it is good practice to enter 
temperature and irradiance values before taking the curve when Auto-
Normalizing.    
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Note: A DS-100 can automatically measure the two irradiances and the two 
temperatures when an I-V curve is taken.   This feature is described in more 
detail below in the Auto Irradiance and Temperature Measurements section.   

 

3.6  Window Menu 

The Window menu, as seen in Figure 29, allows you to move between the Data 
Grid and any I-V curve windows.  The Data Grid is always available in the 
Window menu.  After starting IVPC there are no I-V curve windows open so 
none are displayed.  However, any curves selected, from the Data Grid, or new I-
V curves are listed in this menu if their windows are open.  A check mark 
indicates the active window. 

 

 
Figure 29.  IVPC Window Menu. 
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4.0 TROUBLESHOOTING 
 
• Data is not plotted after taking an I-V curve. 
- Proper connection has not been made to PV system (check DISCONNECT 

switch). 
 
• I-V curve is flat. 
- PV short circuit current exceeds current range (check current range 

setting). 
 
• I-V curve does not start at 0 V (does not reach Isc). 
- Pre-charge fuse has blow (check and replace). 
 
• DS-Tracer Stops Working (Locks Up) 
- Battery out of power (charge battery). 
- Unknown Reasons (reset DS-Tracer  by turning it off). 
 
• Cannot establish connection of external computer to DS-Tracer . 
- DS-Tracer is not turned on or has turned itself off. 
- DS-Tracer serial port is not connected to computer. 
- IVPC is set to wrong COM port. 
- Serial connection requires NULL MODEM cable. 
 
• DS-Tracer will not accept external command. 
- Parameters are not properly formatted. 
- DS-Tracer is not capable of performing command. 
 
• Irradiance readings are incorrect. 
- Pyranometer coefficients are incorrect. 
- Analog circuit requires factory calibration 
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APPENDIX A I-V Curve ASCII File Format  
Note: Each line of the “.IVA” format starts with a unique ID letter followed by a 
space.  The ID letter and space should be used to decode this file.  Line 
arrangements are subject to change as additional information is added to this file 
format. 

  

 “F” curve name 

 “D” date 

 “T” time 

 “S” site 

 “B” sub-system 

 “M” module 

 “P” temperature #1 

 “Q” temperature #2 

 “R” irradiance #1 

 “U” irradiance #2 

 “X” miscellaneous 

 “A” pyranometer #1 constant, temperature coefficient, reference temperature 

  “G” pyranometer #2 constant, temperature coefficient, reference temperature 

 “H” short circuit current 

 “O” open circuit voltage 

 “C” current at peak power 

 “K” voltage at peak power 

 “W” peak power 

 “L” fill factor 

 

   THERE CAN BE 0 TO 257 I-V DATA PAIRS 

 

 “I” current value voltage value   

 “I” current value voltage value  

 “I” current value voltage value 

   .  . 

   .  . 

 “I” current value voltage value 

 “I” current value voltage value 
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 “E” 


